Eaton Logo

Why am I having trouble installing PredictPulse using Internet Explorer 10

PredictPulse is compatible with most browsers including Chrome, Firefox, Safari, and EDGE. Microsoft Internet Explorer 11 and older are not compatible with PredictPulse.